• Los geht´s
  • Software Tips
  • Hardware Tips
  • Scripting
  • Tools
  • Dies & Das
  • Impressum

WordPress Beiträge lassen sich nicht updaten

30.04.16
by Christian
Post, Update, Wordpress
Comments are off

Nach einem Import von Jomla zu WordPress lassen sich Beiträge nicht mehr updaten.
Ich habe meine Seite www.cbfaq.de früher in Jommla gepflegt und bin dann zu WordPress gewechselt.
Die Migration habe ich mit dem Plug-In „FG Jomla to WordPress“ durchgeführt was auch super geklappt hat.

Letztens habe ich versucht alte Beiträge (Post´s) zu überarbeiten was aber nicht funkionierte.
Ich habe auf der Seite kaum Plug-ins die den Fehler verursachen konnten. Super-Cache habe ich
auch deaktiviert, tonnen von Blogs durchsucht wo ich die gleichen oder ähnlichen Fehler vor fand aber keine Lösung.

Der Fehler äußert sich eigentlich nur dadurch, dass nichts passiert wenn man den Text ändert und dann auf den Aktualisierungsbutton drückt.
Wenn ich einen neuen Beitrag verfasst habe und diesen dann ändern wollte hat dies aber funktioniert.

Den Fehler habe ich letztendlich in der Datenbank Struktur gefunden. Einfach mal alte Post´s und Neue verglichen und hier ist mir aufgefallen, dass in der Tabelle „Posts“, die Spalte „guid“ bei neuen Beiträgen einen anderen Inhalt aufweist wie bei den importierten Beiträgen.

Lösung

Bei neuen Beiträgen erzeugt WordPress folgende GUID: https://www.cbfaq.de/?p=336
Die Zahl stellt widerum die ID dar. Das ist nur eine fortlaufende Nummer der Beiträge.
Bei meinen importierten Beiträgen stand aber im Feld GUID merkwürdigerweise der komplette Beitrag oder Teile davon darin.
wordpress_guid

Ich habe dann manuell ein paar alte Beiträge von Hand verändert und den Inhalt
durch https://www.cbfaq.de/?p=ID ersetzt.
Die ID von jedem Beitrag kann man ja aus der DB herauslesen. Und schon konnte ich wieder die Beiträge editieren.
wordpress_id

Um alle Beiträge mit einem SQL Script zu ändern kann man folgendes Script laufen lassen:
Das Script liest die passende ID aus und hängt diese an meine Url hinzu https://www.cbfaq.de/?p=‘,ID
hinter der where Clausel werden nur die veröffentlichten und Beiträge geändert da in der Tabelle ja noch andere Werte stehen.

Vor solchen SQL Updates bitte IMMER ein Backup erstellen!!!

UPDATE `wp_posts` SET `guid`= concat('https://www.cbfaq.de/?p=',ID) where `post_status` = 'publish' AND `post_type` = 'post';

 

(Visited 33 times, 1 visits today)

Die letzten Posts

Directory Opus beta Logo
Directory Opus 13.24.5 Beta ist da
24.07.26
Directory Opus beta Logo
Directory Opus 13.24.4 Beta ist da
21.07.26
Affinity Juli 2026 Update
18.07.26
Directory Opus beta Logo
Directory Opus 13.24.3 Beta ist da
17.07.26
Directory Opus beta Logo
Directory Opus 13.24.2 Beta ist da
10.07.26
Directory Opus beta Logo
Directory Opus 13.24.1 Beta – neue Funktionen im Test
07.07.26

Tags

Adobe Affinity Aktivierung All IP Backup Batch Bilder BITS Dell Directory Opus ESET ESXi Felder Firmware Fotobuch GPResult GPS Greenshot Itunes Koordinaten Lancom Modernize Theme MS Office OKI OneNote Ordner Outlook Plugin POP3 Profile Publisher Rename Server Sophos Suche Tools Treiber Updates UTM Veeam VirtualDub Windows Windows 7 Wordpress

Meistbesucht

  • ProfilpfadServergespeicherte Profile umziehen (5.145)
  • VeeamVeeam Backup Modi Erklärung (3.708)
  • canonCanon Selphy CP800 und Windows 8/10 (3.157)
  • passwoerterPantsOff Sternchen/Passwörter sichtbar machen (3.048)
  • Flexfix_04Opel Astra FlexFix klemmt (3.017)
  • cmdDell Server Lüfter steuern (2.584)

Letzte Beiträge

Directory Opus beta Logo
Directory Opus 13.24.5 Beta ist da
24.07.26
Directory Opus beta Logo
Directory Opus 13.24.4 Beta ist da
21.07.26
Affinity Juli 2026 Update
18.07.26
Directory Opus beta Logo
Directory Opus 13.24.3 Beta ist da
17.07.26
We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.